CX500 GL500 650 Global

The Boss ain't always right,but he's always the boss!
It is currently Wed Sep 20, 2017 1:54 pm

All times are UTC [ DST ]


Forum rules


Use Search function for subjects

No Racism.Slanging Matches(unless witty and funny :)
No spamming.Anonymous posting disabled.Ad bots pay for the site.



Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: clutch problems??????
PostPosted: Tue Jan 25, 2011 1:09 am 
Offline

Joined: Tue Jan 25, 2011 12:39 am
Posts: 1
hey guys,
I've got a gl650, and was wondering if anyone has heard of this before. I changed out my clutch, replaced with new, installed everything according to the manual. torqued it down, put the cover on, hooked up the cable and BAM!! it seems like the clutch it to far in to engage the basket. i ran the bike, it's fine, ran through the gears , no wierd sound. but the clutch will not disengage. i can't ride it and it seems like something was either done wrong on there's something else i don't know.
I could really use any advise, i dying to get back on the road. thanx for any input. DAN


Top
 Profile  
 
PostPosted: Wed May 17, 2017 11:12 am 
Offline

Joined: Mon May 01, 2017 3:16 pm
Posts: 5
It could be a sticky oil in the clutch center. Try to change the oil.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Help keep this forum ad-free - please Donate


This free, ad-free forum is hosted by ForumLaunch
cron
Powered by phpBB® Forum Hosted for Free by Forum Launch